Muso Qb’s days numbered - alternatives?


#42

As a consumer product, Muso/Naim App should be suitable and work fine on 80/90% of household set-up which basically means operate properly on the “average” ISP router.
I agree hiden SSISD is not the default choice of everyone’s set up (although more and more popular), but having to enter the router configuration page to isolate 2.4 and 5GHz networks, assign a fixed IP to a device and disable channel balancing is not something Naim should expect from the average consumer/customer.

I’m happy to honnor Naim with a gold medal for the most 802.11x standard compliant implementation world wide but if, as a result, device/app don’t work properly on the default set-up of a large customer base (which this forum but also many other complaints/reviews tends to show), they just miss the point of what should be a good consumer product IMHO and should rather try to understand why their device/app have problems that 5 years old cheap Android device don’t


#43

The Gorilla has a point.


#45

Which I did and as I said now that I “tailored” my router to the Muoso, I’m enjoying it very much.
But this no excuse to the fact that Naim seems unable to achieve what cheap chineese mobile manufacturers were able to do 5 years ago already :slight_smile:


#46

Only talking for my case of course but I suspect an App issue because the Muso itself seems properly attached to the netwrok. Indeed, Radio streaming was working really fine when the App was not able to find the Muso. It really looks like the App is not able to locate the device on the network (although the Muso is properly attached)


#47

It’s not an app issue. The app works fine if your smartphone has a solid WiFi signal, which apparently it doesn’t. That’s what you need to sort out I think.
Best

David


#48

Who said anything about home router?? I was referring to the device that is running the app… if it’s faulty you should swap it out…so you can then properly operate your Naim.


#49

You might want to do a bit of reading about east exactly it is you’re getting with those wonderful cheap Chinese models you hold in such esteem. It certainly isn’t security and it certainly isn’t the ability to upgrade. What could it be?


#50

Guys, not sure to understand your point here in saying Naim is doing all perectly fine and the rest of the world is doing crap…
I’m just saying there is obviously a LOT to improve in the Wifi implementation of Naim (both device and especially the App).
I’m not holding those cheap chinese device in esteem at all, on the contrary, I’m saying even such crappy devices work perfectly on my network and didn’t need any router trick to do so (among other non crappy devices).

I’ve installed the Naim App on my 2 mains devices : an Ipad and a Samsung S8 and on both devices the experience was terrible (especially on Android ) and I wouldn’t consider those devices as cheap chinese models (although Apple is half chinese actually :slight_smile: ). In both cases the App was nearly able to find the Muso (let’s say it was able to find it 1 out 20 or 30 times).
Facing all those issues I also tried the Andoird App on a Sony Experia and got excatly the same terrible experience (again not a chineese cheap device).
The only way to get it working properly (whaterver the device) was to change the router default configuration (separate the 2.4GHz and 5GHz networks, fix the Muso IP and disable channel balancing, so basically coming back to a VERY basic Wifi set-up). In this environement the App finds the Muso nearly 100% of the time.

As for my Wifi environement/quality, it is good enough to get my Samsung boradcasting HD content on my LG smartTV via DLNA so definitvely neither signal strength/quality nor bandwidth issue here. Also, as stated alrteady, even the Muso was correctly camped on Wifi with good enough condition to broadcast Radio flawlessly but for some reasons the Naim App was constantly failing to find the Muso on the network until I re-configured the router as described above.

You can still claim it is solely the fault of my ISP, Samsung, Sony, Apple and the rest of the Andoird world all together (probabely a conspiration fighting against proper implementation of 802.11x), my hunch/bet is, Naim is doing something wrong here (or something not resilient enough if you prefer).


#51

No really, it’s because your WiFi system is rubbish in the location that you are trying to use the app on a phone or iPad. You can test this by going close to the router (say two or three metres with no wall in between). You should find the app works fine, especially the IOS app which is more developed than the Android one.

There are multiple ways to make your WiFi better where you need it to be and that should be your target I suggest.
Best
David


#52

Looks like you didn’t read my last message.

At the same location where the app was not working I could stream video HD content on my device and also push video HD content to my Samrt TV flawlessly (so both Wifi downlink and uplink are more than sufficient to simply “detect” the Muso).
Furthermore if this was a “location” issue it wouldn’t be fixed by fixing IP, separate 2.4 and 5Ghz network and disable channel balancing.
So location of the phone is OK (since able to stream HD video both ways) and location of Muso is OK (since able to stream Radio).

Problem is only that the App unable to find the Muso on the network despite Wifi conditions are obviously good. To me it looks like the app gets lost when router is dynamically changing the Wifi channel, switch the phone between 2.4 and 5 bands or changing the Muso IP.
I rather suspect the channel balancing or the band switching because even with dynamic IPs, routers generally don’t change the IP every 30 sec.


#53

I did read all your messages but I’m not sure that you understand how WiFi works. My Qb just sits on my WiFi network here and always works. The app can always find it (and my other Naim streamers) whether the phone or iPad I have picked up is on the 2.4 GHz WiFi band or the 5 GHz WiFi band and whether the phone/iPad is on the same wireless access point as the Qb or another one. All my stuff has IP addresses set by the router and none of them are fixed.

Anyway ignore my advice if you wish. It makes no difference to me.

Best

David


#54

Not sure what the advice was but indeed, not really important since I fixed the issue already.

My point here was to share to others the router changes that solved the problem for me because obviously many customers are facing this broblem of App not able to find the Qb (happy for you it worked without anything to change on your router).

My second point is that listing the changes that were needed on the router, it tends to show that the Naim App/Device have obviously a fairly sensitive (not to say poor/not resilent) Wifi implementation in comparison to many other devices not having any kind of problem in the same Wifi netwrok environement & location.

For some reason I hardly understand, some people seem to think that nothing needs anykind of improvement because it is working for them.

I’m saying if many customers not having any kind of Wifi issues with none of their many Wifi devices (even for services as demanding as video HD streaming) start to have basic problems such as not being able to find a device on the network although it is properly attached to this network and this only when using the Naim App/Device, there is obviously something Naim needs to improve.

Maybe not a coincidence Naim already advice in the troubleshooting section to seperate 2.4 & 5 GHz network
I beleive they should not only add more tips but also improve their implementation.


#55

As has been mentioned already by S-i-S it’s your device that the App is running on that may be faulty. Have you tried another device. I have three Android devices including an Amazon one that had to be side-loaded to get the App on and none have any issues.
I assume when you say ‘fixed’ IP you mean reserved at the router as opposed to a true static IP? If this is the case the IP still gets renewed at the end of the lease but just receives the same one it had previously.
What’s your network configuration e.g router,switch etc


#56

Hi Guinnless,

Thanks for the constructive approach.
To answer your question, the IP is reserved as far as I can see on the router admin page (but not much details provided on the method used to be honnest). But again let me clarify that the issue took place with the default configuration of my ISP router (where IP was managed automatically by DHCP).

Default set up :

  • 2.4 & 5 GHz combined (same SSID & pswd)
  • Channel selection managed automatically
  • IP autmatically managed by DHCP
    With such set up, App was most of the time unable to find the Qb although Qb was properly attached to 2.4GHz and was streaming radio flawlessly.
    I tested the App on 2 Android devcies (Samsung S8 & Sony Xperia Z both supporting 2.4 & 5 GHz Wifi) and on an 5 years old iPad (only capable of 2.4GHz Wifi).
    IPad was able to find the Qb slightly more than the Android devcies but still missing it most of the time.

“Fixed” set up :

  • I separated 2.4 & 5 GHz networks
  • I manually selected a specific channel for the 2.4 GHz network (the less busy)
  • I reserved a specific IP for the Qb
    With such set-up it works fine on all the devices listed above (even when the controlling device camps on the 5GHz Wifi)

What I didn’t try yet (and will do when I have the time and the kids not after me each time I make a change on the router that interrupt the service :wink:) is to revert one by one those “fixed” settings back to default to see if one has more impact than the others


#57

The reserved IP would be the first to be removed if it was me.

I have few if any 5GHz devices so I disabled the 5GHz. Everything else is default on a BT Hub 5 so all Wifi devices get whatever address DHCP supplies.


#58

Indeed Wifi connectivity and Wifi bands are completely seperate to IP addresses… like chalk and cheese.
The optimum way of working is IP addresses obtained by DHCP for host clients, and SSDP is used to discover UPnP devices. If your home network and especially Wifi is sub optimal SSDP might not work reliably so you may want tell DHCP to assign pre assigned IP layer addresses.if your Wifi is really poor you may want to consider manually assigned IP addresses on the hosts, as DHCP may have become unreliable… but I would not recommend this.


#59

Why disable the 5GHz band… that will disable 802.11ac and limit the ability of 802.11n. I would have thought unless your Wifi devices are all severel years old, you will have some clients using the 5GHz band, which then gives more space for those only able to use the 2.4GHz Wifi band such as the Muso.


#60

My WAP is a repurposed BT Hub 5 connected only to the 2960 has nothing connecting to it apart from my Lenovo Pad (for Naim and Bubble) and the Muso and the Lenovo doesn’t support 5GHz either. However prompted by your comments I’ve changed the incoming BT Hub to the default of combined 2.4/5 on the same SSID.
I’ve just checked my host list on the BT Hub and my Amazon tablet is the only 5GHz device :smile:

As advised by yourself I’ve enabled IGMP on the 2960 :sunglasses: and I have zero discovery or streaming issues. Is there any benefit to enabling 5GHz on the WAP?


#61

It’s IGMP snooping that should ideally be enabled on the 2960, though the performance impact in not using is going to be minimal for most home network uses, although always beneficial to use on wifiaccess points where ubiquitous broadcast messages are otherwise a bad idea. … anyway I must admit I thought IGMP snooping was enabled by default on the 2960… I can’t remember… but you have it working well it appears and that’s the main thing. :grinning:

The optimisation i have previously referred to is about enabling an IGMP Querier on the 2960… that needs a little bit of config… but that keeps Airplay, wireless printers, and UPnP devices nice and responsive on the whole of your subnet from a multicast group discovery perspective.

Enabling 5GHz on a WAP allows the 5GHz portion of 802.11n to be used and allows 802.11ac to function, assuming your WAP supports it, which many now do.
The 802.11ac Wifi protocol is more efficient, potentially allows greater throughput and can allow various optimisation for real world performance… though do bear in mind due to coexistence mechanisms, the overall performance will be constrained by the oldest protocol on the band… which on 5GHz could be 802.11n if enabled.
5GHz Wifi/ISM tends to be less congested as well, but has greater attenuation through walls etc.


#62

Simon, yes it was the IGMP Querier that I enabled as per your instructions on the old forum :blush:
I’ll enable 5GHz on my WAP (Hub 5) and see how it goes.