Naim app for iOS 5.20 crashes

@Richard.Dane Good to hear that you are improving the Naim app. However, I am experiencing crashes in the Naim app for iOS 5.20 on my iPhone 11 with iOS 14.4 whenever using Qobuz. Please fix and update ASAP.

I’ll let @tomvamos know.

1 Like

Please elaborate on your experience. Working fine here with qobuz.

I faced the same problem today. The app crashed 5times in a row.

I killed the app each time to be sure. It happened while I was scrolling in Qobuz library.
Now no crash anymore.
It’s a bit weird.

It was around 18:00. Maybe a problem from Qobuz

Last app 5.20
iPhone XS on iOS 14.4

Hi @Julien and @Joamato, would you be able to describe some steps that regularly recreate these crashes please. Also, could you provide some environment info (Naim product, wired/wifi, iOS device info).
Thanks, Tom

Nova wired directly to my ISP router.
iPhone Ios14.4
Naim app 5.20

It happened each time I was trying to launch a Qobuz playlist
It’s weird because the app crashed 5 times.
I did nothing special except I killed Naim App.
Now the app doesn’t crash anymore and I can’t reproduce the crash ( so far)

Thanks Julien.

Just had the same. iOS 14.4, iPhone XS Max. Atom connected by wire. App crashed right after I have switched the atom on from the app. After I restart the app atom is preselected but the app crashed again.

I’ve experienced the same issues. Sometimes when picking albums or playlists in Qobuz the naim app crashes. When I restart the app it’s okay for a few selections then crashes again.
IOS 14.4 new iPad Air and iPhone XS Max

Maybe time to expand the beta testing groups.

I’ve deleted the app, reset iPad and reinstalled app and signed into Qobuz but still the same problems.

Current research suggests there’s an issue with unexpected Qobuz data format. Started at 1500 today. Will be talking to Qobuz ASAP.

Ok cool, thanks for letting us know :+1:

Just did the following with the Naim app version 5.20 on iPhone 11 with iOS 14.4 in 5 GHz WiFi network with Naim Unity Nova:

  1. Start a song from NAS in WiFi network - worked
  2. Start a song from a Qobuz Album - worked
  3. Start another song form another Qobuz - crashed
  4. Start the App again and start a song from Qobuz Playlist - worked
  5. click on Qobuz icon - worked but crashed last time
    => Seems to be indeterministic and might depend on Qobuz

Yes, my Naim app has just crashed and closed itself about 20 times in 20 mins when streaming from Qobuz on an iPad into an ND5XS2.

FWIW I tried the described things for a few minutes on Android and could not make it crash

I had a crash on an instance of the app that does not have a qobuz account

From the technical team at Qobuz: “There was an issue with our API yesterday and it has now been fixed. There is nothing to change in the Naim App, and we apologise for the inconvenience”.


Good that it’s resolved, but I would disagree with that last part. An issue with an API should not make the app crash. Maybe the song wouldn’t play, you’d see an error message, etc. it should be gracefully handled.

1 Like

Indeed. Those are Qobuz’s words. While we can’t anticipate every anomaly in 3rd party content or response, we can harden our systems with each of these incidents. This recent one, if you’ll pardon the pun, is no exception.
Thanks, Tom