NDS plays only 25 % of 33.19 minute DSD file?

Allright,maybe one of you knowledgeable lot knows what is wrong.
Got hold of a SACD from The Allman Brothers Band, Eat a Peach.
On it is a long track called Mountain Jam that has a duration of 33.41 minutes.
My NDS on firmware V4.7 plays only 8.19 minutes of it. Says also it is just 8.19 minutes on the Naim app on my iPad.
Makes no difference whether I use USB or network as input.
When I use Foobar on my PC it plays the track entirely.
Tracksize is 1.392777 GB.
Anyone has a suggestion?
Bug in NDS firmware? I really suspect that but I am open to suggestions.
Track is a DSD64 DSF file

Hi
This problem was already mentionned in a recent thread. I experienced it several times with DSD files > 1 Go. It seems to be a bug or limitation from NDS

I don’t think this is a problem with NDS & 4.7 software…
My NDX with 4.7 plays DSD perfectly, I have quite a number at aprx 100 & these include bought on-line & also a few ripped from SADC
My money is on whatever software it was ripped with, what was that ??

1 Like

@Mike-B Don’t know for sure. was not ripped by me. Accompanying logfile says SACD-Ripper Version 0.21.
rings a bell?

@Lio84 Happen to have a link to that thread?

Sorry does not ring bells
Do you have dBpoweramp, or know someone who does.
If so I would run the dBp ‘Convert’ function & convert whatever DSD it is that you have to a dBp DSD.

@Mike-B Hmm good idea. I’ll try that and let you know.

To be precise, it was an iso file and I used Sonore ISO2DSD to extract the DSD files.

The link :

@Lio84
Thx!! Sounds exactly as my problem and I think he uses the same software judging by the name ISO2DSD_gui.
Going to look into it. Mike_b could be right. Will post results here.

Used Mike_B’s suggestion of dBp conversion. But dBp converts it to a PCM WAV file. Not a DSD file. It makes not much difference as the same is done in the NDS by the firmware. Anyway, the result is a >1GB file and that plays correct.
Problem solved? Mwah it is still a Naim firmware bug as was also reported in the other thread. It is workable but I find it a bit disappointing that a free available piece of Windows software does what a €10k high end audio streamer can’t…
In the other thread the guy that reported the problem only got a deafening silence from Naim support on his inqueries about the status of this bug.
Given that Naim has discontinued the NDS I don’t think there will be a solution for this.
Quite disappointing for a brand that positions itself as high-end…
Naim should be very,very,very ashamed of themselves.
Just my 2 cents.

It should not have converted to WAV, if you select Convert - DSD it just runs thru the file & corrects any errors.
What version of dBp have you got ? I just tried it on my R17 & it works as I would expect
And no its not a Naim f/w bug, else why would mine play DSD correctly

Okay, try that. I have version 16.3 and it only lets me convert to flac or wav. No option for DSD there.
See if I can get a hold of V17 tomorrow.
But I do think it is also a firmware bug. I quote from the other thread:

“The issue was brought up on the old Naim forum when I was trying to find out if others had the problem. I contacted Naim to let them know and after doing some testing they recognised there was an issue. They said it would be solved in a future firmware update but so far this has not happened.”

Anyway,thanks to all for the input. It is now clear to me how to handle this.

I reported it to Naim back in 2018. It only seems to affect legacy streamers. To be honest I’ve given up with Naim coming back to me on this. When I contacted them, they asked me to send them example files which I did. Incidentally, one of them was Mountain Jam, ripped from my MFSL SACD! They confirmed there was an issue and that they would look to fix it on a future firmware update. I’ve contacted them several times since but unfortunately you end up speaking to someone different and going through the same process. The last couple of times I’ve tried, they didn’t respond to my emails. I’m not sure why as I was very polite.

Anyway, this has nothing to do with how the tracks are ripped. I’ve tried playing the same files on a Naim Atom and they play fine. I use iso2dsd to rip my SACDs to iso and then convert them to dsf files. All of the files affected exceed 1GB in size so that seems to be the limitation.

Hi all. I started the thread that Lio84 referred to above.

My conclusion is the same as Olik’s. The issue is clearly a problem with the legacy streamers (NDX, NDS), even with the most recent firmware, not being able to play .DSF files larger than 1 GB regardless of the source of the file. My work around for my few recordings that have tracks this long was to convert them to hi-res PCM files using the freely available Tascam file converter (easily found through a search engine).

I sent an email to Naim support about the problem on March 29 and received a reply on April 2. To paraphrase from that response - “the request has been sent to the software team… they do look at implementing customer requests when possible”. No further response since then.

We are dealing with a problem with legacy technology that only applies to tracks larger than 1 GB, not exactly a huge number of recordings. Sad to say, but I doubt that fixing this problem will float to the top of the priority list any time soon, if ever.

I do not understand this. My NDX with 4.7 plays DSD OK, irrespective of size over 1GB, including with more than one DSD album in a play list . It always has , and this is going back to the first beta firmware that was released with DSD capability.

I should add that my local streaming is from a Synology DS214 NAS with Asset UPnP software

That is interesting.

Are you using a Naim server as well? I don’t recall the situation of the others who have reported this problem, but I am using an Innuos Zen 2 server. I’m wondering if the problem then might be somehow linked to communication between the server and the Naim app? Recall from my earlier post that I had no problem streaming these files to my home theatre system using the media app for my Oppo 103 Blu-ray player.

I don’t think it has anything to do with the server. As said, I have the same problem when I put the file on a USB-stick and play it through the NDS USB port.

Mistery solved, I think.
There 2 formats for a DSD file, a .dsf and a .dff file.
DSF is the Sony format and DFF is the Philips format.
Only difference between the 2 is that with DSF you can add metadata and with DFF you can’t.
Obviously almost everyone chooses DSF,and so did I.
So instead of ripping the track to DSF I now ripped to DFF and voilá, problem solved.
So looks like it is caused by a filesize > 1GB and the presence of metadata.
Still think it is a firmware bug though.

I don’t think that the whole story, you might have bypassed whatever the real problem is
ALL my DSD albums are .dsf
DSF carries metadata, DFF doesn’t

If you use dBpoweramp to ‘Convert’ DSD to DSD, it will be .dsf
You did say you were going to do that, did you ???

Once again, you are barking up the wrong tree thinking this is a Naim firmware bug, if it was I would have the same problem & all the other many NDS/NDX users with 4.7 & the other legacy product users would be up in arms

1 Like

Nope, still have to get a hold of dBp V17. I have V16 which does not let me ‘convert’ to DSD format.