NDX 2 Garbled Hi Res

Good Morning… ran into an issue with my NDX 2 since the last firmware update. 24 bit audio is playing back garbled and at half speed… with lots of noise. It only affects 24 bit streams and it comes and goes. A hard restart fixes the issue, until it mysteriously crops up again.

I did some looking and see there is a closed thread on the topic, so thought I’d post a new one so the powers that be were aware the issue is still out there. The feedback on the thread was that Naim would be addresssing the issue with a future firmware update. If there is an update on the status of the fix, would love for someone from Naim to contact me and advise.

You should send a message to support@naimaudio.com. The forum is not routinely checked by anyone at Naim working in a support capacity.

I have a different problem I will post here, but will also contact Naim - I can stream just fine at CD quality, but via hi res, it is all cut up: the stream is not constant. It doesn’t matter whether I am streaming via the Naim app or the Qobuz app. I have the problem both via wifi antennae and wired directly to the router. There is no video, no competition with televisions and the like. I contacted my provider, and my service is superb (various tests were run), so I thought I’d look here to see if other people had similar issues.

Hi @zipperheadbanjo

On the support ticket state the server being used (and software version running on it)as we have found on many times that its bugs in the upnp server on the NAS.

Currently we don’t have anything noted on the v3.6 release that this is a Naim problem, but I’m open to be proven wrong.

Finally, a good sanity check is pop the same music files on a usb stick and play it from the front of the unit. If it plays fine then the problem being in the upnp server/NAS is high.

Best wishes

Steve Harris
Software Director
Naim Audio Ltd.


And i forgot to say why it goes garbled:

On UPnP the server can provide options of different streams. Some servers just provide the files native, some decide to offer options and transcode to different formats. We’ve found that some servers have bugs in 24bit and beyond support and produce a mangled audio file if played. It’s intermittent as its down to the sequence that the server lists the streams available on the control point (aka user app) which then sends the url to the streamer to play.

Reboot either end and the streams offered by the server can change. The best bet is try and turn off any transcoding options.




where would you turn off any transcoding options? I fully rebooted my NDX2, have spoken with my service provider, and still get constantly interrupted streams in hi-res.

Hi @Drinkwine

Your problem is something completely different.
Chromecast and Qobuz has issues on hidef (Chromecast just isn’t really designed to handle beyond 96kHz, but Qobuz send unsupported streams and hope it will play). However when playing from inside Naim via the Naim app it handles it fine and we buffer many minutes of audio. If its dropping out it indicates it just can’t get the data from Qobuz’s data centre or there is a local network issue (eg. streamer is connected on 2.4GHz, not 5GHz or wifi is using a channel that has interference on).

Another good test to check the system is go to Internet Radio->Hidef Radio->Radio X. They broadcast a realtime 2Mb/sec 24bit/48kHz stream. See if it plays reliably.



Hi @Stevesky, thanks much for this. Trying to narrow it down. But your message raised another issue: you suggest playing from inside Naim via the Naim app. The problem with this is that I can’t seem select the full work. In other words (we’re talking strictly about classical music here, haven’t tried with anything else) it “samples” 30 seconds of whatever piece I want to play, and even if I try to play the whole album (or work) it limits me to 30 seconds. How do I get rid of this? It was this problem that led me to stream via the Qobuz app. Thanks.

Qobuz thinks you are logged in too many times. I think they allow 3 devices, with only 1 thing streaming at once. I would log out of qobuz everywhere, then login to qobuz in the Naim app only.


Thanks for this - I’ll try it. It’s curious, because I did have same problem with my QB2 and I don’t think I had the Qobuz app opened on anything other than my iPhone.

But next question: my NDX2 is connected to two different preamps - a NAC82 and a Conrad Johnson Premier 14. I have the output selected to activate both the RCA and DIN connections. Yesterday, both were working, but today, only the DIN is operational. All connections are sound. I can play vinyl on both. Ideas?

Have you tried switching the din / rca options on and off in the app to see if they both come back?

yep. Only the din is working. Actually, if I select just the RCA option, I get no sound.

Maybe try a factory reset?
ref this thread NDX2 No audio from analog output - Streaming Audio - Naim Audio - Community

did that too.

Ok,@stevesky and @robert_h so I solved my cable issue. (Looks like I had to clean my RCA connections.). But I have an issue with the Naim app whether I use the QB2 or the NDX2, even after logging out of Qobuz as you suggested earlier: when I choose Qobuz in the Naim app (and Qobuz is not open on any other device) and I choose to play something (eg a. Beethoven Piano Sonata), it only will play a 30-second excerpt. I could not figure any way to make it play the whole piece. So this is why I used the Qobuz app to stream. As noted, I first had this problem with the QB2. Is there a setting on the Naim app that I am missing?

If you have logged out of Qobuz you would expect only a 30 second clip. Perhaps you need to check that you are not connected on more devices or apps than your Qobuz account allows, log in on the Naim app (if you’re already logged in, log out then back in) and see what happens.
Sometimes a restart of the streamer and app is required after the log in.

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.