New firmware update

2nd random reboot today. Playing via usb stick and trying to adjust volume via the Naim app, which was very laggy. Seemed to make the Nova “crash” and reboot whilst doing this. App didn’t crash. Suggest there may be some interface issues. Reported to Naim support with the description given here.

Hi all, for the past week or so when I play tracks from Qobuz it’s like playing vinyl at the wrong speed (slowed down) and crackles and breaks up.

Anybody else had this problem?

I’m assuming it’s related to the firmware upgrade as it never happened prev.

Internet radio is fine and some albums via Quobuz are fine, but then (like just now) I tried 4 different albums and they were all broken…

Regards, Carl

Have you tried the two steps of resetting your streamer?

  1. Turn it off, unplug it, leave it for 5-10 mins and then plug back in, and/or
  2. Do a full factory reset.

Also recommended to reboot your router before powering up your streamer again.


Unfortunately this process didn’t work in my case as I’ve experienced two further random reboots since.

As there might be a possibility of incurring a random reboot whilst not playing, I’ve taken to pausing play midway through an album and leaving it like that when not in use. If there’s then a reboot while I’m not there, it will have lost the album selection when pressing play on the remote. At least this will be indicative of any such event without it being necessary to check the DHCP log.

Same here no response whatsoever, quite disappointed…, and also besides the response still awaiting a solution.

Bert, what’s your support ticket number?

My only issue currently seems to be that the app (Android) intermittently loses the upnp servers on my network, using the webclient does always show them however. Probably not related to the firmware specifically, but it’s a recent issue that didn’t seem to happen earlier.

I’ve just added my name to the seemingly ever growing list of folks with streamer problems … see my thread “The Sound of Silence” elsewhere.

I received the following response “Please be aware - we are experiencing unusually high numbers of incoming contacts, etc” … quelle surpris!

Grrr. Went to reboot just after cueing my first play for today.

A broad timeframe for the fix wouldn’t go amiss @Richard.Dane if you have any sway?



No idea I’m afraid Graeme. I would guess once the next beta looks good for general release.

1 Like

Problem solved, Chez Dave.

Having carried out a “so called” Factory Reset, via the remote and ND 555 front screen, I Googled “ND 555 Factory Reset” and found instructions not contained in the, frankly, less than comprehensive product manual, other wise known as the “Quick Start Guide”.


The music is back … phew, but does it really have to be this difficult?


Hi Richard, do you think it might be worth flagging this info up as a sticky, since there does seem to a be a difference in functionality between the Factory Reset procedure in the product manual, and the one above, which has finally resolved my post firmware update problems?

1 Like

Think I’ll try a factory reset now. Just to eliminate the variables.


It has had a factory reset so the countdown begins. Fingers crossed.

Also deleted and reloaded app.


Dave, AFAIK this has always been the reset procedure and is available on the website FAQ so shouldn’t be needed as a sticky here. Not to be confused with what I believe is termed a “hard re-boot” as more recently advised…

No worries, but there’s definitely a difference between the “soft” reset with the remote and screen combination, per the manual, and the holding down of ND 555 buttons whilst powering it back up again.

Just seems odd that this info isn’t in the product manual.

Just for my future info, what does a “hard re-boot” involve?



Re. Re-boot, support’s official advice is as follows:

Close the Naim app (don’t just minimise it).
Power off (unplug) the unit and leave for a good 10 minutes or so.
In this time, it may also be worth rebooting the router, just to give everything a chance to refresh.
When the router is back up and running, switch the Naim unit back on and allow to fully boot up.
Then open up the Naim app, connect to the appropriate ‘Room’.

If you are using any streaming services then log out first and log back in last.

Sorry to appear sceptical, but how do you know? Surely, only time will tell.

Well, this time yesterday, I had no choons, other than directly from the HDX, and today, the streamer is back functioning normally.

What I don’t get, though, is the different Factory Reset procedure outlined in the manual, using the remote and front screen, and the “hands on” one I unearthed earlier.

As to the future … :crossed_fingers: :crossed_fingers:

1 Like

After my Nova froze when installing the latest firmware (error 310 reported earlier in this thread), it had been running fine until it just performed a reboot. I’ve sent Naim support an email. Since the spontaneous reboot, the overall sound seems a bit fuller (a little more bass) to my ears so not all bad news. :slightly_smiling_face: