No iRadio on my Muso Qb unit

Navigate to the stations in the iRadio menu, play them, then resave them. It will then work. There are a couple of threads on this.

Thanks Robert, it’s the bbc stations. I’ve tried the hard reset, but no joy,

Thanks HH, I’ll try this,


There are several other threads about this temporary issue with BBC iradio. It’s always worth checking what other people have posted as you may get your solution more quickly.

I have a Muso Qb gen 1.
I cannot get iRadio to work on it any longer.
I go to the Focal&Naim app (on my Android phone) and connect to my Muso device. Then I go to the iRadio section. The wheel just goes round for ever and if it ever does stop (it isn’t stopping now), it only finds 8 regional podcasts for Gardener’s Question Time ! I cannot get any live radio stations.

Does Naim still support iRadio in the Qb gen 1?
Which Internet Radio supplier does this connect to? I read somewhere that it was vTuner. I went to vTuner and none of their BBC radio stations are working.

My Muso Qb still plays Spotify fine, so I think the WiFi connection is working well.
The problem seems to be specifically with iRadio.
This is very disappointing, as the functionality of my Muso Qb has significantly reduced. The radio stations I normally listen to (and want back) are BBC Radio 3 and BBC Radio 4.

Thank you, Alistair Morfey
Cambridge, UK

The referred to thread is getting quite long but the answers are in there.

I had the same issue but it then cleared itself. The recommended answer from David Hendon in that thread is:

“Did you do a full power off restart of the Qb or just on and off with the button/logo? I meant a full power off restart. If that doesn’t work, try doing a router restart and turn the Qb on again once the router is fully back on line.”

I have fully powered off the Muso Qb gen 1 (pulled out the power cable). This did not change anything, so did not solve the problem.
I have not power cycled by WiFi Router. I will try it this evening. However, I don’t understand how this could affect things? The WiFi and Internet connections are fine (which is why Spotify works fine on my Muso Qb). There is no data stored in the Router, so I don’t understand how it could work for Spotify, but not for iRadio.

Does the Muso Qb gen 2 also use iRadio, or does it provide internet radio a different way?
Does Naim iRadio use vTuner? If so, how can the Qb support BBC radio stations when the Vtuner website does not?

Thank you for your help.
Best regards, Alistair

I think this might be a defect with your Muso Qb.
As you note, Spotify plays OK indicating the internet connection is OK & thats your iRadio connection.
It might be worth another power cycle, but if that doesn’t work, it needs to go back to Naim

Thanks for everyone’s help.

The fix was to delete the stations from my favourites and find them again on iRadio and resave them

Thanks Phil
Did you do this in the Naim App on your mobile phone ?
Are you Apple or Android ?
I am Android.
I have deleted the favourite iRadio stations in my Naim app, but now cannot get any radio stations to appear in iRadio in the app. That’s why I’m stuck.

I don’t think there is a problem in my Qb gen 1 hardware.
I think the problem is either in the Android Naim app, or in the internet radio station it points to?
Is this Vtuner? I keep asking this question, but no one has answered it yet.

Thank you, Alistair

I have just seen this post …

The BBC are on the final stages of moving to the token authenticated streams. For those that have had BBC stations stored in presets for a long time, you might need to browse to the BBC radio section, pick the station (it will hopefully play), then re-save the preset.
RegardsSteve HarrisSoftware Director**Naim Audio Ltd.

What do you mean by the “BBC radio section”? Is this in the Naim app? In the iRadio section?
I cannot see any BBC section.
Indeed I cannot get any radio stations to appear in the iRadio section of the Android Naim app at present.
Thank you, Alistair Morfey

yes it’s v-tuner. Ignore BBC for the present and try any station say from ‘naims choice’ folder or wherever just to see if that works first. If you select ‘internet radio’ you should see folders containing various stations etc

This is what I see on my gen 1 muso Qb on my iPhone screen in the Naim app:

Thank you David
That is very interesting and helpful. I wish I could see pages like that in my Android Naim app.
I do not see any folders or radio stations in the iRadio section of my Android Naim App.
I just see the spinning wheel going on for ever.

It seems that the Apple Naim App works better than the Android Naim App.
Could Naim investigate this ?
Thank you, Alistair

Alistair, have you contacted Naim Support?

Hi Richard
No. I have not contacted Naim Support.
I thought the website asked us to raise such issues through this community forum, and not to contact their support directly ?
Do you think I should contact Naim Support ?
By telephone or email ? I’d prefer email, as this is a complex issue to explain.
What email address should I use for Naim Support ?

Thank you for your help.
Regards, Alistair

Here you go - contact info is at the bottom of the support front page;

This evening I powered off my home router and the Qb as you suggested. I then turned the router on. When the Router was up and the WiFi working, I turned on the Qb. This made no difference. The Android Naim app still had the wheel going round when I selected iRadio.

2 hours later I tried the Android Naim app again. At first the app had the same problem. I pressed the Android Back arrow a few times (to try and get back to the main Qb page), and then the radio folders and icons started to appear! This was at about 11:15pm.

I don’t know if something has changed at the Naim server or at vRadio, but the system has sprung back into life for me and everything seems to be working fine! From the Android Naim app I can see lots of folders and radio stations in iRadio, even the BBC radio stations. They all seem to be working fine !

This is great news. Let’s hope it stays like this going forward.

Have you changed anything at Naim or vTuner? If so, Thank you !

There was something seriously weird going on with the BBC yesterday in this neck of the woods anyway. The Qb1 would not hold any BBC station - it would start and then cut out (router and Qb1 rebooting made not a blind bit of difference), normal Freesat stations went down, Freeview was working and then just stopped (“No signal”). Ended up having to watch Only Connect on Freesat BBC Northern Ireland.

This morning all is normal except Freesat BBC2 still reports “No signal” even after retuning.