Qobuz Only Playing One Song at a Time via Naim App

Hi, I’m new to the world of Naim and the use of streamers in general. These forums are great though and I’ve certainly learned a lot through them. I recently purchased a ND5 XS2 with the main intention of streaming Qobuz. However, when I try to play any album/playlist of any file size natively via the Naim app, playback will end completely if a song is longer than about 4:09 minutes long. When I go back into the app, the display returns to the first song played. The ND5 is ethernet wired to full fiber internet (180mbps+) via a Cisco 2960 switch and then to my internet provider’s router and then to the wall. I’ve tried logging out of everything and logging back in, full factory resets of the ND5, and wiring the ND5 directly to the wall/router, all to no avail. I can Chromecast Qobuz, but there’s a noticeable loss in SQ from the Naim app. Has anyone else experienced this, and if so, how did you resolve it? Many thanks in advance.

I have a NDX 2 with SN2 and no problems with Qobuz. I can not offer a solution but did you bring home and set up yourself or did your dealer install?
Have you called your dealer with help troubleshooting? Also you may want to contact Naim Support.

For help with all Naim product installation and operation please use the following details:

T: +44 (0) 1722 443405

Hours of service are Mon-Fri 9:30am-5:30pm GMT/BST

…hopefully someone will chime in shortly to give a hand.

I set it up myself. I’ve also discussed with Naim Support, but still no solution, so I thought I would put it to the forum in case anyone else had a similar issue.

Do you have any local content you can stream eg wav or flag files on a nas? If you play using the qobuz app it all works, but not via the naim apo is that right? That would suggest it’s not an issue with your qobuz account. Have you tried removing your qobuz login details from the naim app then reapplying?

You should be able to play this album perfectly ; the beatles / beatles for sale. Every song apart from 1 is less than 3 mins.

Same for help, rubber soul, revolver.

Try this one, blue nile “hats”, shortest is 4 but otherwise 5 or 6 mins per track. How far do you get? Will it play track 1 all the way through?

There’s clearly something not quite right but with so many variables at play it might prove difficult to pin down. What i can say is technically it should work without issue, you should be able to stream anything regardless of bit rate or track duration.

I had something similar on my ND5XS2. Played a track or two, sometimes more, and then stopped. Being an OCD type of person, I found that track length seemed to be a factor. 4 minutes seemed a magic number; if a track was longer then the streamer forgot to play the next one and stopped until I got involved and started the next track. I played with a lot of settings on the streamer and iPad, spoke to Naim etc. It has been better since the last firmware update but it is too early for me to guarantee that it has been totally cured. The last thing I did was to mess with the iPad app settings, so that it is always on in the background. Costs me battery life but perhaps that was the key?

I don’t have any local files unfortunately. I either stream or play vinyl. The issue only exists with Qobuz natively through the Naim app. Songs will play consecutively if under 4:09 minutes, but stop as soon as one song is longer than that. If a song is more than 4:09, the full song will play, it just won’t play the next song.

Qobuz/Spotify via Chromecast work as expected.

And yes, I’ve tried logging out of everything and logging back in. It didn’t resolve it.

I’ve tried leaving the app open on an iPhone and iPad during playback, but that hasn’t resolved it for me.

Is there a difference between 16/44 and hires?
I’m wondering if this is buffer related, the naim streamers i think buffer 50mb but that shouldn’t prevent continuous playback.
Hires will fill the buffer more quickly.

No, initially I thought it was just hi-res related, but it affects 16/44 as well.

Rem automatic for the people, sidewinder sleeps tonight 4:09 on qobuz. 16/44 and 24/48 available. Took a while to find something!
The preceding track is shorter. I’m guessing you can play track 2, track 3 sidewinder might complete, track 4 is over 5 mins.
(My own flac file is 53mb at 24/48)

Who from naim came back to you, how was it left?

@robert_h I appreciate your research! In the 24/48 version I can play track 2 into track 3, but then it stops. On the 16/44 version, I can play tracks 2, 3, and 4 and then it stops. Track 5 eventually started playing about 5 mins later, then stopped again.

Naim have noted that this has been reported to them previously, but it’s not widespread, so have suggested requesting a replacement from my dealer. I was hoping to avoid that.

I’m ex naim hence the curiosity. From your experience it would seem to be something to do with maxing out the buffer though that shouldnt effect the player from continous play. You’ll be fine if you stick to the beatles but prog rock is going to be problematic. If you do rma the unit i imagine r&d test will be interested. All units should operate the same!

At no time has Naim suggested that it is a player fault. Their main suggestion was that it was related to the wifi network or my internet. Unfortunately, I am not expert enough to fiddle with that. However, for me, the consistency of when it stops in terms of track length tells me that there is something specific here and some kind of network gremlin would be more random.

My previous thread is ‘Naim App just stops playing’. I think you might find some interesting parallels to this thread

I somehow missed that thread previously. Thanks for sharing, but also sorry that you’ve had the same issue. It’s really frustrating.

The network side of things is certainly not my area of expertise either. Naim did a scan of mine though and there was nothing out of the ordinary. It was strong, if anything.

1 Like

Hi @stormZ

Could you email me on steve.harris(at)naimaudio.com
Let me know your ticket number and I’ll pick this one up and we’ll arrange to log into your system and see what is wrong. For one thing, you have fuelled my inner-geek on what is wrong as very unusual fault description.

With regards

Steve Harris
Software Director
Naim Audio Ltd.

Thanks @Stevesky. I’ve emailed you.

Hi Steve, I hope that you can fix this for @stormz, and please let me know if the investigation comes up with anything that I could profit from. My ticket with Naim in this was 77499, and we finished the dialogue with the advice that it was Qobuz or internet related. We did not go as far as to question the streamer itself and I eventually got my ISP to change to a newer router ‘just in case’. As I live in Switzerland, everything is a bit more complicated when it comes to troubleshooting, and not least because my language skills are somewhat limited! The Naim dealers are, however, a nice bunch but this problem had them flummoxed too.

Along time ago I accidentally set in Tidal to repeat, when i used iPeng the control app or even the Naim app it would play the same damn track again and again, drove me nuts, until a fello forum member spotted the error.

So maybe worth checking ny Qobuz app settings and also bear in mind Qobuz can be at fault, i recall going nuts with a 30 sec issues, for some reason the Qobuz app confused my subscription plan so on quite a few tracks just play a sample.

I have played with a number of settings on the app and in Qobuz. The benefit of this forum is that it brings your issue in front of knowledgeable people and shares experience. Of course, the downside is when you realise that you truly have an obscure issue that others have not encountered!