Roon with original NDX

I have just signed up for the Roon trial.

However I did know that my very old original NDX (with 192 upgrade) would not work (Roon does not support native UPnP). I know the best way is to use a hardware device and link to the NDX, but at this stage I do not want to go down this route until I am sure Roon is the worth what it costs.

I know there are software bridges available, & I have searched the forum, but although I can open a CMD line terminal, write and copy from an example, I am not really that confident, and I still couldn’t find a step by step guide.

I did also download LMS, with Spotify & Tidal Apps & the UPnP added but struggled again. I could get LMs to see all my devises including the NDX when I added the UPnP bridge, however when I selected I could not get the NDX to play. I could get Spotify to play through my Marantz AX amp, but Tidal would only play 3 seconds worth, and then restart. Lots of configuration option in each App & bridge but again, I am not an expert.

So it looks like back to Roon. My NDX runs with 202 & 200 with a Marantz AV Amp supplying the 5:1 element and 200 driving the mains & then just as a stereo. Due to location, I have my NDX ethernet connected to an Apple Extreme unit which also has ethernet connection to WDMyCloud with all my ripped WAV’s on. As the NAS with WD is poor, the Extreme then links wirelessly with my router connected to my iMac running Asset Server which works well through then Naim app.

If the Extreme was an Express I could “hard connect” it too the NDX as Roon see’s my other Express’s, but of course no output on the Extreme.

So in simple terms, is there a software or other quick way I can test Roon, to do I need to get my old Raspberry PI B out and try & set something up via this route…and search for a step by step guide.

My apologies for the verbose detail, but I have been thinking & trying over the past couple of days.

Many thanks in advance.

So it looks like bad

Do you have a Google Chromecast Audio device by any chance…that’s a good option for just trialing Roon into legacy streamers if you don’t want to use RPi

1 Like

Using a raspberry pi is straightforward, there are dedicated distros, but you can also install stock raspberry os and then download and run the Linux bridge set up script from the roon downloads section.

Roon Bridge armv7hf

$ curl -O http://download.roonlabs.com/builds/roonbridge-installer-linuxarmv7hf.sh
$ chmod +x roonbridge-installer-linuxarmv7hf.sh
$ sudo ./roonbridge-installer-linuxarmv7hf.sh

2 Likes

Only problem with the RoonBridge is that you’ll need a HAT to provide a digital out to feed the NDX otherwise you are restricted to the analogue jack out or USB neither of which help with NDX

Yeah the hifiberry digi+ is £28 plus postage and works very well even with the stock psu.

1 Like

For best sound quality the bridge approach either using a Sonore device or the free lms-to-upnp software is preferred. For me this sounds no different using Roon to Asset running off my QNAP and streamed services like QoBuz also sound as good as local music.

If you have a Windows PC or MAC then lms-to-upnp is really easy to get up and running. If you are lucky it will probably be 10 minutes work. I’ve not done this on a MAC but the pointers below for Windows should help you through this.

Firstly make sure any UPNP devices you wish to use with Roon are switched on and available on your network.

For Windows download the package, and unzip.

Open a command line and navigate to the bin directory (use the change directory - cd command)

Type squeeze2upnp-win.exe –i config.xml

This will run for about 30 seconds and search your network for any UPNP devices. It will create a configuration file called config.xml

Before using you need to edit the config.xml file, use a text editor like Notepad. You need to change the following lines

<roon_mode>1</roon_mode>

Change the 0 in the default file to a 1. If you don’t do this then your device will appear in Roon but will not play.

<sample_rate>192000</sample_rate>

This will set the correct maximum sample rate for your NDX.

Now start the program again without any command switches, i.e.

squeeze2upnp-win.exe

You should now see your devices in Roon and be able to play them. If you cant then it could be the firewall on Windows, you can verify this by temporarily disabling it.

Assuming that this works then there are some options available to ‘productionise’ this. I run lms-to-upnp within Logitech Media Server using a container on my QNAP. A Raspberry Pi also works well.

I suspect the reason why you had trouble with Logitech Media Server is that you didn’t update the <roon_mode>1</roon_mode> line in the config file. You also may have been trying to run Roon and Logitech Media Server on the same computer which won’t work.

Finally if using Logitech Media Server I found I needed to add an extra command line option to tell LMS where my Roon server was otherwise discovery was hit and miss, mainly miss. Obviously change the IP address to your own Roon server!

4 Likes

Firstly…thanks to all for taking the time to respond.

Robert, thank you for the link to hifiberry, this looks like a potential permanent solution.

What I will do in the meantime is delete the LMS (which I was just seeing if it could do what Roon, does with the appropriate plug ins) and just leave the Asset on my iMac. I will then try the lms-upnp as suggested. I will then see if Roon can see my NDX.

If anyone has an “idiots” step by step guide to do this on my iMac, it would always be appreciated.

Thanks again.

Try this, he has it working by post 25, hopefully the false starts help you get through it ok.

1 Like

HI Robert,

Many thanks for this…

I have looked down & if I can find out how to “get to the correct bin”, I may be able to do this.

Probably needs to be on an IT forum, but some bright minds on these boards I know. I have the following files…

I then have this on my terminal…

So how do I get to correct bin?

I can the probably follow the guidance suggested by Robert.

Also how do edit the xml file…I need to change a 0 to 1 for one of the lines…

Again a basic step by step guide would be help.

Thanks again…

A simple text editor should be good for this.

On linux at least, you can right click in file explorer and select “open in terminal” which gets you into that directory.
Otherwise you need a “cd” command, cd = change directory
If you can detemine the full path, then it would be something like:
cd /home/andrew/my\ files/upnpbridge/bin

pwd command would show you your current directory so you know where you are starting. You can also do cd by cd into each folder, so:
cd home
cd andrew
cd “my files”
cd upnpbridge
Etc

1 Like

On my MacMini I usually have to go into preferences and security to allow me to download files before I can install the squeeze files. I use the forklift app to move files around from my download folder to applications. I then highlight the relevant file, squeeze2upnp-OSX-multi-static in my case, and under the file tab request to open the file in terminal. I also use forklift to edit the config.xml file.

The one thing I’ve not managed to do is to edit a startup script so that squeeze2upnp to run once my MacMini has rebooted after a software update.

Thank you…the right click worked & opened in the right bin.

However when I ran this, I got an error loading config file

I think that given by terminal knowledge, I am going to have to settle for either a hardware solution that comes packaged, or bite the bullet, get my NDX screen replaced (usual fade to death problem) & PX for a NDX2.

Again, thanks to all, and a great example of how helpful & knowledgeable all on this forum are…

Hmmm it doesnt like the config file, rereading the instructions it seems this command creates the config.xml file which you then edit afterwards. If it is there, rename it to something else and the rerun that “sudo” command.
If that runs ok, edit the new config.xml file and make two changes:

Quoted from post above

Before using you need to edit the config.xml file, use a text editor like Notepad. You need to change the following lines

<roon_mode>1</roon_mode>

Change the 0 in the default file to a 1. If you don’t do this then your device will appear in Roon but will not play.

<sample_rate>192000</sample_rate>

This will set the correct maximum sample rate for your NDX.

Now start the program again without any command switches, i.e.

squeeze2upnp-win.exe

I think you may have a permissions issue that is stopping the Config.xml file from being created.

I set this up on a Raspberry Pi to try the bridge once and made some notes.

I had to do a

sudo chmod 755 squeeze2upnp-armv6hf-static

You would need to change squeeze2upnp-armv6hf-static to the name of the program you run.

I also changed ownership of the directory, in my case to the user called pi

sudo chown pi UPnPBridge
and
sudo chown :pi UPnPBridge

Given that the Mac runs Unix I wouldn’t be surprised if you need to do similar. I’m not a Unix/Linux expert but somebody else may chime in here and assist, @simon.pepper maybe?

1 Like

There are also additional parameters on the executable to force it to use a certain Config file in a specific directory.

./squeeze2upnp-armv6hf-static -i config.xml

See Roonifying my systems - #22 by Jack

Have you checked the iFi upnp Bridge?

I’d post a link to the YouTube video of it but I’m not sure if that’s breaking forum rules or not, so just google it. I know some members have got it working by this method.

Simon & trickydicky…thank you for your patience. I seem to be getting the hang a bit more of UNIX style terminal!

I can right click on the folder to now get myself in the right directory. I have also noted that one version of the download I had (which I have now deleted and cannot find) had an executable file for OSX in the bin that if double clicked, processed in terminal. However I got the same error loading config file. I note your comments, but again, this is for arm (RaspberryPI) and is the same xml action as OSX…so still stuck

Weekend Warrior…I was very excited…found the YouTube link, but unfortunately only for Windows & my Roon core is on my iMac…but it looks a great solution for windows users.

Just checked on my Roon, and something must have worked…I now have this…

How do I identify which is my NDX please?

Check the config.xml file that was generated. Here’s one i found:

Yours i think must have “raopbridge” 6 times, one of these will be the ndx.
You can disable the ones you dont need via the xml, change value of “enabled” to 0.
You need to know the mac address of your ndx, check in the naim app, in settings then “about”.
You can then correct in the xml file so it says ndx instead of raopbridge.

1 Like