The Naim app is so janky

Yes, I agree about the app volume control and always have the remote control with me as it gives better volume control.

1 Like

Didn’t realize this but have noted quite a lag navigating Qobuz as my favorites numbers have grown. Do you think there will be a solution? Would it be a Naim app or a Qobuz issue?

I was very dubious about how system automation would work, having had a 272 with its brilliant volume control, but I find the app is really good for volume control. Both small and large adjustments work perfectly. Maybe I’m easily pleased.

1 Like

I think I just prefer the tactile nature of the remote, the app does the job fine when I use it. It’s good to have both options.

I much prefer my old fashioned SN3 Narcom to the cheap and nasty plasticky abomination that comes with the NDX2.

My suffering made me the expert on this :wink: All of the below is for Android, I do not know about iOS app in this regard. The phone and tablet are quite current. Issue was much worse on the tablet as it has a slower CPU (Samsung Tab A 10.1 from 2019 with Android 10)

Originally I used Tidal for years, long before deciding to go all-in with Naim. Because the streaming company apps have just the binary favorite yes/no choice, I ended up with approx 2000 favorites, as it is the only way if you want to remember something. Annoying but what could I do. Then I started to use a NAD streamer with the Bluesound app, used Tidal from within it without any problem. Then switched to Bluesound Node, also no problem.

Then, last summer, I started to use the Naim app, back then with a Nova, and initially had so many issues that I don’t know anymore what was what, but one major issue from the start was that whenever I woke up the app (from sleeping screen or just by switching from another app) it was unresponsive for 5 or 10 but also up to 30 seconds. So essentially unusable. Reinstallation and so on not helping. What’s worse, you never knew if it was already responsive and when you tried to drag the volume slider while it was still unresponsive, it would then add up the attempted slider movements later, after it had become responsive. So occasionally it would then magically move the slider higher and higher, making you struggle to run to the unit to turn its knob.

After the September app update, the unresponsiveness got better and was “just” 2-5 and up to 10 seconds after every wakeup or app switch. The scary volume behavior did not happen after this update. I asked on the forum, people said “your network”. I contacted the Naim support and they also said “probably your network”. Which I knew not to be true, but of course I complied with whatever the support wanted to do. They scanned my network and it was confirmed that this was not it. As they could not help further and as I could kind of live with the level of unresponsiveness (and using the remotes for volume), I did not pursue it further because it looked hopeless. (There is another user on the forum who also contacted support and unfortunately was told, according to how he described it, that he was using it wrong and should use fewer favorites. Not very satisfying after spending thousands on a streamer, one has to admit).

In Nov, I switched to NDX2 and shortly after to Qobuz. Same problem. I joined the Beta group. While working on a report for an unrelated app issue, I happened to log out of Qobuz. And lo and behold, the unresponsiveness was gone! I could have thought of trying this earlier, but it just never occurred to me.

So I reported this in the beta group where, to the Naim staff’s credit, I was finally taken seriously and indeed it turned out to be a Naim app issue. As a Beta member I shall not speak about what is going on in the Beta, but I believe nobody will be angry with me for saying that I am happier.

Try to log out of Qobuz and see if the overall responsiveness when touching various things in the app improves, in particular after wakeup, then you know if you have the same issue.


Is it a Narcom 5? Lovely bit of kit and makes fine adjustments of volume easy.

1 Like

Another annoying thing…

I’m playing this Cream Goodbye Tour. It’s 4 separate CDs or volumes in Tidal. The Naim app just crams them all into one long list of songs. I want to play one gig at a time. You can’t even tell where the volumes start/end. Now that’s janky!


That’s the one.

Thanks. Certainly easy to try.

When I tried an NDX2 it worked fine, but from memory only if variable output was set not fixed.

1 Like

Ha, indeed I never tried. Might need a reboot:

Of course the caveat applies that Naim did not intend this to be used, but easy to try.

I’m not having any major problems with it but that’s maybe because I’m not using it the way you are. I don’t overly bother with Favourties Flow. I’ve got a couple of favourites and it’s more than good enough for that. One annoying thing is the way Naim loads a maximum 500 tracks so when I click my music folder on the NAS to play randomly, it tends to pick the same 500 tracks.
Other music apps can randomise my entire collection which is nearly 40,000 tracks. Clearing the UPNP cache is a bit of a palaver but other than that I’m happy enough with it.

I’ve created multi-volume albums on my NAS just fine so it could be that Tidal’s metadata is janky.
The Naim App just displays what it is sent by the server.

I’ve contacted ISP and network has all been checked out and the router doesn’t appear to be the issue or the network speed.

It won’t be the network speed. Usually the issue is because some commercial routers badly implement the standard protocols that Naim use. That’s why other stuff works ok but the Naim app appears not to. Restarting the router usually fixes the issue for a while, but changing the router for one that works properly fixes it properly.



That seems somewhat of a poor argument for Naim not being able to facilitate a broad range of network environments.

Most commercial/consumer routers are sold by a factor of 100 to 1000 or more than Naim equipment is, i feel it would be the Naim app’s responsibility to be flexible in this sense.

Also the Naim streamers are really quite standard in terms of network implementation as well, they are just small linux machines, as almost all of the commercial routers are. And the apps are just standard Android/IOS apps, there are no special considerations that would require a very specific or strict implementation of certain network protocols, as far as i can tell.


All the other stuff works but not Naim, must be the other stuff’s fault.


For what it’s worth, i’ve only had standard network equipment at home myself, currently a Zyxel ADSL modem and a Netgear Nighthawk router, and i’ve personally never had any technical problems with the Naim app or the network discovery.

My main issues are with the functionality and UX/UI of the app, not it’s stability.

Same here. Well, I don’t have feature/UI issues any more because I stopped using it …