Uniti Nova - Can't Wake Display

I’ve noticed several times that when I turn on my Nova, the display resolutely stays blank. Pressing buttons on the remote or the unit won’t make it come on.

The only way I’ve found to resolve this is to disconnect mains power and restart it.

I’m trying it now with the Turn off Display During Playback option set to off to see if that helps.

Is this a known issue? Or perhaps a gremlin in FW 3.2.0?

1 Like

FWIW it’s happened once to me with the same solution necessary. But only once (so far!).

1 Like

Happened to me too. I just gave it a bit of time and after around 3 minutes the screen lit up by itself.

I also have all display issues on my Nova described by @Hollow in the “Uniti software update is here!” thread („locked home screen“ and „display doesn’t wake up“ after the Nova powers up from standby). My display off option is turned off in the app settings. Sometimes putting the Nova into deep sleep helps, and another time only pulling the mains plug does the trick. I hope there will be a fix out soon.

The same …

I had the same problem on my Atom. Yesterday it seems the display died and I can no longer resurrect it, no matter what I do. Not even a factory reset helped.

Unplug the power chord.

Thank you for the tip about unplugging the power chord but I have already tried all the remedies mentioned here and in other threads. Also the factory reset mandates unplugging the power chord. This one is going back to the dealer.

You are not alone …
Have a look to the thread.

1 Like

Display on my nova had been fine with it coming on for 10 secs when vol change etc is commanded from either Roon or the naim app but tonight nothing. Reboot and it’s fine. Nova was in standby for two days.

Same problem with my Unit Star. I think its a bug in 3.2.0

1 Like

Same issue happening here. 3 or 4 times now since the latest update. I did have an error code come up after I unplugged the power cable this time though:

Warning Fault detected Error code: 311

I had to unplug the power cable one more time and it finally powered up like it should.

Is there any way to reboot without disconnecting the power cable?

Hold down the power switch for long enough and it powers down into full standby.

1 Like

Much appreciated!

I‘m sorry but this can‘t be the long term solution.
Is there any official Naim statement?

No. They know there’s a problem and have provided methods of possible ‘fixes’ but nothing definite as yet. The ‘fixes’ don’t seem to work for some either.
There are a couple of other threads dealing with this so you may want to look at them as well.

have a very similar issue with my atom ioccasionally the display will completely freeze the whole system will work normally via the app only disconnecting the power and having it reboot will restore normal function I m running 3.2.0.4222
seems like there ugh be a general bug in his firmware… (not sure how similar the atom and nova are but its suspiciously similar is there a naim bug reporting process?

The problem appears on Nova, Star & Atom with 3.2 firmware although not everyone is afflicted. Some seem immune while others report issues.
The best thing to do is email Naim and report your problems.
We have had many discussions and theories posted here and none have so far fixed the issue.
Naim say they are aware of the issue but that’s as far as it goes at the moment. No sign of a fix yet.

1 Like

A possible work-around:

My Nova seems to get ‘stuck’/freeze on the home screen when I switch to the ‘internet radio’ input from a ‘chromecast’ input.

Although a cycle through ‘deep sleep’ (long hold of the standby button) would usually fix it, I stumbled on an easier way to ‘unfreeze’ the screen.

With my remote, I tap the ‘up arrow’ so that it highlights ‘home’ at the top of the Nova screen. I then tap the center ‘enter’, then ‘return’, and finally the ‘down arrow’ to the main home screen. Voila, the screen is working again and will display whatever is currently streaming.

I is probably a firmware or display driver bug that should be fixed in the next firmware update.

I hope this works for others.
Marty

I have had it confirmed by naim that this is a known bug and a fix is being worked on … no further detail unfortunately

1 Like