Uniti Star problem CD

Hi guys,
I have a problem with the Naim Uniti Star.

It’s already the fourth or fifth time that I turn it on, insert the CD and the player doesn’t read it and both on the display and on the APP it indicates “no disc”.
I can’t get it to play or eject the disc, the only way is to unplug it and reboot so it can eject the CD.

I bought it a week ago.

Does anyone know what the problem is?


It could be one of a few problems, but if you only bought it a week ago, you should take it back and discuss how to sort the problem out.

1 Like

Is it only the one CD or is it any CD?

Different CD

In that case, take it back to your dealer immediately because it’s faulty.

1 Like

I tried with a fabric reset :crossed_fingers:

I tried to do a factory reset but still the same problem.
I understood that it only does this when the Uniti is “cold”, when I turn it on after a few hours, such as when I return from work or this morning. Now I had to unplug the cable 2 times because it wouldn’t even eject the CD.
I have already contacted my dealer :man_facepalming:t2:

Morning Tony,

I just raised a separate question about this because I’m also experiencing the same on a recent unit. I haven’t been able to link it to anything specific about the disc. I haven’t been in touch with the shop yet because I didn’t feel they would have much more to offer than the experiences on here and I don’t have to leave the house for that. So I’m tagging along for any responses!

If we keep responses in this one thread that might be easier but I’m not sure I can close my other thread.

@Richard.Dane can do that for you.

1 Like

Info you might want to share: serial number of unit, or at least the first 3 digits to give a rough age. (Are the 2 units of a similar build date?)
CDs that work / don’t work. Non red book standard etc.
Temp fixes that bring it back to life.

Hi Robert, these are my info

Hi prag,
I’m on contact with my dealer.
Is a good friend of mine, I hope he can find a solution soon, but for me the only solution acceptable is to have a substitution.

I’ve looked through a few threads on here but haven’t seen anything quite like this so I thought I’d ask separately. I’ve had a Uniti Star for less than a month(!) but it seems to struggle with CDs.

I place a CD into the slot, it’s eaten and then the machine doesn’t detect it. Of course I can’t therefore eject it and retry. Using the eject hole doesn’t fix this. Only on a full power cycle will it eject the disc itself. When the unit is restarted I can insert the disc and it plays as expected. Then this happens all over again… I’m presently power cycling daily!

Also, if there is a CD in the player when I bring it out of standby, sometimes it ejects the disc unilaterally. Sometimes it doesn’t, however.

Both of these things are fairly annoying when you have someone round and they tell you that their £200 microsystem doesn’t do this but can also stream spotify from their phone. I never use the CD drive for ripping, only playing audio CDs. I’ve also determined it happens with any type of disc, not just those weird, mixed mode ones. Pure audio CDs are also affected by both of these issues.

Has anyone else noticed anything similar or could this be an issue with the CD drive on my unit? The unit isn’t obviously flakey in any other way.

See here

1 Like

How do you find these things?! haha. Thanks.

(Oh it’s in streaming audio that’s why. CDs aren’t streaming audio.)

A chap called Graeme seems to have some thoughts but he’s keeping them to himself for now!

I have same problem… :unamused:

1 Like

Nice suggestions: a reference to a topic for which no outcome has been reported. The substantive solution suggested is if a reset does not work, return to the dealer…

Wouldn’t it be helpful and better to (just a friendly suggestion on my part :heart:) empower people by providing information on this forum that will help people solve this issue themselves?

1 Like

If there was a simple answer, then someone would provide the information. But the point is that this isn’t a problem with the Star that regulars here have seen often at all and as it’s starting to look like recent examples may show the problem, it probably needs investigating by Naim, which you do by contacting Naim technical support or by taking the unit back to the dealer for them to replace it with one that doesn’t show this fault.

Definitely talk to your dealer, and if no resolution, push for an rma. Hopefully that should get the QA alarm bell ringing in Salisbury. Yes all this data gets flagged and cycled back to R&D who monitor everything.
Could be anything eg bad batch of teac cd rom drives.

1 Like

I’ve merged the threads.