Unity Nova frozen and on/off butten blinking 5 - 4 - 2 after reboot

I rebooted my Unity Nova yesterday, but it won’t come to live. I left it unplugged overnight and tried to restart this morning. The system powers up, and the network icon indicates that it is connected to the router. However the system won’t respond, nor to the remote, nor to the app on my phone. After a while, the screen turns off and de on/off button starts blinking 5 - 4 - 2.
The behavior looks identical to what is described in the thread started by Suedkiez linked below, but I don’t find there how the problem was solved. Anyone any ideas?

I fixed it with a factory reset: “Anyways, a factory reset fixed it now.”
However, it may not be necessary as somebody else got this info from Naim support that a soft reset may fix it so try this first:

If you do have to do a factory reset, note that this loses all settings: https://www.naimaudio.com/product/uniti-nova/support

As far as I know, this problem is also expected to be fixed in the upcoming firmware update.


If the above doesn’t work a quick call to Naim support is your best bet, they sorted my issue out in 15 minuets.

1 Like

Thanks, Suedkiez, for the reply!
I’ve done the factory reset, but after reset, the same error occurs. I’ll try to get hold of Naim support to sort it.
Thanks, anyway!

Will do! Factory reset didn’t resolve the issue.
Thanks for the suggestion!

Oh wow. Good luck!

I had the same problem with an Atom. It happened after the unit was transported by DHL from the dealer. Underneath the lid, the volume control is connected with a ribbon cable. It likes to slip out and leads exactly to the symptoms mentioned. The dealer told me, after opening the case, the cable can be carefully pushed back in. After that, everything should work again. But beware, after opening the unit, the warranty expires. So this is more of an RMA case. Therfore I had to resend it to the dealer.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.