Qobuz via Naim App on ND5 XS2

I recently added a ND5 XS2 to my Naim system. I previously owned a Node 2i and I moved from Tidal to Qobuz before buying the ND5 X2. no problem with Qobuz via BlueOS App, but now. using Qobuz via Naim App, sometimes I’m facing malfunctions such as Qobuz not responding to commands, or not skipping from a track to the following of the same album or playlist, or returning at the begining of the playlist, for example, and stopping the playback!

did anyone experience such kind of issues? have you got any suggestions?

thanks and regards,

I can’t help you with your specific problem I’m afraid but I’m just about to return my second Blue Node 2i to my dealer as I’ve had nothing but problems using Qobuz with the Blu OS app.

Same sort of thing, the app or player loses connectivity with the router or my queued songs suddenly disappear or I have no art work.

I’m also very disappointed with the overall sound quality. It’s nothing like the reviews suggest. My iPad into my Ndac is quite a lot better.

Sometimes such problems arrive. The first thing to do is restart your router, wait, then restart your nd5xs2. Then you can also install the app again. A general restart, like with a computer.
A wired connection to the streamer may help too.

I had similar issues with tracks not linking together but the latest firmware update cured it. The only curiosity now is that a search on the Qobuz App returns more results than through the Naim App. I sometimes need to search by unconventional methods to tease out the result that I want.

thank you!

the ND5 XS2 is wired and the firmware updated. anyway I’ll follow your suggestions. regarding the Naim App, I’m wondering if may the iPhone release be less performant than the iPad one, for instance, causing such kinds of problem.


I don’t think so.

I suppose, as stated in my previous replay, that the firmware is updated because during the configuration at home, two days ago, the App cheched out the firmware status.



1 Like

I think I’ll move back to Tidal for a while (I still have some remaining days of subscription) to see if the same problems occur anyway.


hi Njb, I found a topic in wich you and others were talking about the same issue:

it seems that somebody from Naim Support solved yours problems…


1 Like

Hi Stefano,

Yes, Naim contacted me directly and provided an advance copy of firmware 3.6.0. I had instructions on how to do an ad hoc load, and from that point onwards, it has all worked fine. However, I believe that 3.6.0 is now on standard release and so if you have it, then it could be a different issue.

I’ve just contacted Naim Support.

currently my ND5 XS2 is running 3.5.1 firmware release. no further upgarding possible via Naim App. hope they will provide a copy of 3.6.0. to me, too! :wink:

thank you for your support. :pray:


I don’t know if this is specific to the ND5 XS2 or if Qobuz is acting up, but last night all 24/96 tracks now pause during playback and start again several times. It might or might not play all the way through, but it does this on everything. 16/44 seems fine. Any clues?

in my experience the pause is only at the end of one track, not during the playback of it. and the pause occurs if the track last more than about 4 minutes, as also someone else experienced (see my previous post).
finally, it doesn’t depend on the file resolution.

Yes, I’ve been looking through many threads on the topic and they all seem to have separate issues—some with resolutions to the thread and others gone unanswered. In my specific case, if it’s a hi-res album any track inevitably stutters or pauses during playback, then starts. It is completely random at what point in the song this happens, so it’s unpredictable. Length of track, beginning, middle or end—doesn’t matter. Very frustrating, since I do not know if this is a Naim app issue, Qobuz issue or ND5 XS2 issue.

That sounds like a buffering issue to me. Hi res tracks need much more data, and if your ND5 is not getting fed the data through the router quickly enough then the buffer will run dry. If this only happens occasionally, I would be checking that nobody in the house is streaming video and thus competing with you, or would do a quick speed check on your internet connection.

Agreed. However, I’ve had zero issues since owning the ND5 XS2 until last night. Internet is solid. I have an Ethernet connection, too. It’s just strange. My streaming hasn’t struggled since moving on from the NDX.

Indeed. As the new streamers have 50 MB buffer, it’s hard to make it stutter. You can pull the ethernet cable and it will happily continue playing for several minutes. And even 24/192 hi-res uncompressed uses only roughly 10 Mbit/s data rate

Exactly. It has led me to believe it is not the Naim. So deductive reasoning tells me it’s either Qobuz or native Qobuz within the Naim app. I rebooted my wifi configuration and did a signal test and it is golden. No one in the household is doing anything differently, either. Not much TV watching/streaming here, so not a lot of bandwidth being taken up; at least not enough to warrant me thinking it could be the network.

FWIW, I have been happily streaming Qobuz, in Germany, though through Roon. Can you try streaming with Qobuz app? If it was their servers, one would hope their app would also be affected