UPnP and Wi-fi Issues

I’m having trouble with the Naim app (Android) and my home network. My current Wi-Fi setup uses a Netgear Orbi router and satellite mesh network. I can’t run everything from one router within my house, due to poor Wi-Fi transmission. Using the mesh network, Wi-Fi is strong throughout the house, and I’m using a wired backhaul between the router and satellite. I’m experiencing very slow response times when browsing UPnP servers, specifically using Synology media server, and Minimserver, running on the Synology NAS. Due to other home networking tasks, my NDX and Synology NAS need to be connected to the router and the satellite respectively.

When browsing the media servers using the manual buttons on the NDX, response times are near immediate. When the Naim app is used, however, I experience delays of up to 30 seconds, often more than 10 seconds, after browsing for music on the media server – basically its almost unusable. I have tried other UPnP apps on the phone, but I lose gapless playback on the NDX, so they are not an option either. Once I eventually get to select the music on the Naim app, playback is faultless. I’ve tried turning many Wi-Fi settings on and off in the router, but have yet to find the root of the problem. So my first question, is are there any particular settings that I should be paying attention to on the Orbi that would enable me to fix this, or any diagnostic approaches people are aware of to try to work out what’s going on?

The situation is made even more intriguing, when replacing the Orbi router and satellite, with an Asus mesh network router and satellite. In that configuration, the app browses the media servers almost instantly, perhaps with a second or two delay occasionally. The obvious answer would be to ditch the Orbi mesh, but in most other regards they are a better fit for my Wi-Fi network than the older ASUS routers.

I may just be having the timing issues referred to here, NAIM App - UPNP Server not found, but I’ve been unable to confirm that. The Orbi’s don’t support IGMP snooping so changing settings related to that isn’t an option. As far as I can see, I only have one DHCP server on the network.

Timing link referred to in the final paragraph here

How does the main Orbi router connect to the Internet? If you are using a router supplied by the Internet provider you need to run it in modem mode and not router mode, otherwise you will have double NAT that may be causing your issues. If you can’t turn it into modem mode set the Orbi into Access Point mode and turn the Wi-Fi off in the ISP router.

Also ensure the Orbi are running the latest firmware by checking on the Netgear site as the check in the router web interface often does not show up new firmware.

Thanks @XMB, I’m on Virgin, and the router is in modem mode. I’m also running the latest firmware on the Orbi.

Is the orbi in AP or router mode?
I have a similar system, a orbi RBR 50 + a backhauled satellite, about 20 devices connected via 3 switches including a Synology NAS and a NDX2 and I have never experienced this delay browsing my library via Synology media server or Asset.BTW you can try to see where is the problem in your network using a Synology integrated app called EZ internet. Start this program in DSM and it will show you some network issues.

Thanks @Peppo62, my RBR50 is in router mode. I tried EZ Internet and everything is green apart from ‘Checking network environment’ which displays a red triangle, but offers no explanation as to why there is an issue. I tried dhcploc and that only displays one DCHP server on my network.

:+1: I don’t know if it could be a problem within the Naim app. I have the IOS version and it works just fine,but I red here on the forum that there are some issues with the Android version. Anyway hope you will fix it!!

@Peppo62, are you using your RBR50 in AP mode? If so, what router are you using?

No .I use it in router mode. Btw I’ve disabled both NAT and. DHCP in my ISP modem/router to avoid any conflict between it and Orbi

Hmm, perhaps its an Android/Naim app issue then with the Orbi router - my Virgin router is in modem mode, so NAT and DCHP should be off…

Really don’t know. I don’t use Android devices so no idea about it :pensive: