Usb stored music

Since latest firmware update to my NDX2 some of my usb memory stick music files do not play from USB. There was not any problem before update. The same USB memory sticks play perfectly in my muso.

All recorded in Flac format. Stick is formatted in NTSC. Does anyone have any ideas? Has update changed the format required say Fat32 for example but most of the files will play?
Had problem when first purchased NDX2 and was told to use NTSC format.

Think you mean NTFS.
NTSC is a DVD regional format.

It’s probably the usb stick brand that doesn’t work in your case. Try another brand like Sandisk, which works very well.

There were two other reports about problems with USB playing. One is here and affected done hires files, reason unknown, Naim is looking into it:

One was caused by & characters and possibly others in file names:

Two Kingston NTFS worked before update to NDX2 both128gb.
Sandisk FAT32 also has the same problem. All work through Muso.

Also tried through rear USB port of NDX2 but same problem. £14k worth of Naim kit in total, should life be like this?

If it’s not messy characters in the file names, did you do the usual dance of turning off and unplugging the streamer for 30 minutes, rebooting all phones and tablets, and finally trying a factory reset if nothing helps?

Just to re-affirm this for the OP, as someone else had an issue recently, and they had “&” in the filenames. Just as an experiment, rename one of the files to something very simple

Genius. All the files with & somewhere do not play although not a problem on muso and NDX2 before latest firmware. Nightmare to try and change all my files. Naim must solve this that they created?

Thanks for your input.

It may not easily be fixable if they have moved to a new software libraries that don’t support all special characters, but perhaps they should at least mention this new restriction in their release notes.

Also happens to me. Different pendrives and disks is the same. Emerson lake palmer’s 1st album, I have it in different versions and formats and it doesn’t play any of them. Same with other discs. They are usually whole discs. Don’t check the “&” thing. When i can i will

I’ll never understand why CD rippers don’t default to using only safe characters in filenames when most have the option anyway, or why anyone uses them in download files. It’s causing so many problems and always did. Luckily it’s not such a nightmare: There’s bulk file-renaming software which can rename all your files based on patterns, so it’s easy to tell it to leave out ampersands and others you may have used.

E.g. one of several:

@Naim.Marketing this is becoming a bit of a problem with several members already affected. Can the software team do something about this?

I certainly hope it’s fixable, because at present it is not a viable option for me. Most of my 1.5TB library is classical, and - to take the most extreme example - the 555 Scarlatti Sonatas in my box set are labeled Sonata #1, Sonata #2 . . . I would have problems with thousands of other tracks as well.

@Suedkiez I contemplated using JRiver’s expression language to make bulk changes, but after taking into account not only ‘#,’ but “No. _” and all the foreign characters in operas, other vocal works, composer names, titles of movements etc., I realized this would be a monumental task. It might be possible (but ugly) if the expression language had an ASCII Value function - then I could change all of the non-standard to 'QQ ’ or something. But it does not.

We’re crossing posts. In response to your last comment. I have used LMS and JRiver in the past and am now using Twonky without any problem. I also don’t recall having a problem with GooglePlay/YouTube Music

As mentioned you could simply bulk rename them to change # to Nr or something. Annoying as it is, it’s never a good idea to have these characters in filenames, it’s a recipe for creating problems. It’s more of a surprise that they ever worked rather than they stopped working now

My problem was my NDX2 not reading USB and we have found that after the update any file with. “ &” in a title would not play. I now know Naim plan a further update this month this month to resolve it.

1 Like

Before we go any further, what is the problem you have? Also with USB, as is the topic on this thread, and did you establish which characters are a problem? Usually it’s only characters that have a special meaning in certain filesystems and operating systems that are a problem. So not foreign characters like ø or whatever, but #, &, * and the like

I know, that’s what I told you. I don’t know if jegreenwood has the same problem or a different one

So far no problem. I was warned by Naim support before I went that route. (And I requested a fix.)

Ah ok then, that’s at least something :slight_smile:

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.